Friday, March 21, 2014

Installing Meld on Mac OS X

I really don't like FileMerge.app: I've always been feeling that Mac OS was missing a good tool like meld. Actually this turns out to be simply false: installing meld on Mac OS is pretty simple. Here are the steps:
  • Install the great macports.
  • Install meld. This will take some time. Keep in mind that at the time of writing, because of a bug, it is necessary to install rarian first:

    sudo port install rarian
    sudo port install meld
  • Start the dbus service and make it start at boot:

    sudo launchctl load -w /Library/LaunchDaemons/org.freedesktop.dbus-system.plist
    launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist
  • Define the LC_ALL variable to your locale (i.e.):

    export LC_ALL=en_US
  • Run meld (i.e.):

    /opt/local/bin/meld
Pretty simple! Bye! ;-)

Comfortable Logcat Output on Linux and Mac OS

Android's logcat is really a brilliant tool for analysis and debugging. Unfortunately I really don't like using it from Eclipse and using from the shell is not entirely comfortable, being it completely uniform. logcat-colorize is a great tool to colorize logcat output and make it really clear. Many thanks to the author! Unfortunately it was not working on Mac OS, so I forked and fixed; everything seems pretty OK: you can find the final fix in my fork at the moment.

How to Build

Follow the readme for building on Mac OS. The project depends on boost, so install it through macports and simply make. Assuming the boost libs are in system paths or default macports paths you should be good to go

Download the Binary

If you prefer, I also built a static version that you can download and use right away on Mac OS 10.9. This version does not require boost or macports to be installed.

Bye! ;-)